« IPMessengerプラグイン公開開始しました | トップページ | sourceforge.jpはじめました(ipmsg4e) »

2005.09.19

早速バグ発見(IPMessengerプラグイン:コア)

j2sdk1.4.2(Windows,Linux)でEclipseを動作させているときに,何らかのメッセージを受け取ると文字列解析に失敗(NoSuchMethodError)する。コアのバージョン0.0.1を公開したので,j2sdk1.4.2を使用している方はアップデートして欲しい。

外見の現象としては,ユニキャストを受信できないというものだった。開発開始当時,DatagramSocketの使い方を間違っていて,ブロードキャストされたものしか受信できないという全く同じ現象がでたので,「あれ?JDK1.5とJDK1.4.2でDatagramSocketの実装が違うの?VMのバージョン見てDatagramSocketの使い分けしないといけない?」とか疑ってしまった。

なんてことはない。JDK1.5から搭載されたAPIを使ってしまっていただけのことだった。早合点してしまった自分に反省。orz

|

« IPMessengerプラグイン公開開始しました | トップページ | sourceforge.jpはじめました(ipmsg4e) »

コメント

コメントを書く



(ウェブ上には掲載しません)




トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/12631/6014238

この記事へのトラックバック一覧です: 早速バグ発見(IPMessengerプラグイン:コア):

« IPMessengerプラグイン公開開始しました | トップページ | sourceforge.jpはじめました(ipmsg4e) »